Pinball Nirvana Home Page

Go Back   Pinball Nirvana Forums > Real Pinball > Maintenance & Repair

Maintenance & Repair Discuss and offer tips on real life machines.

Reply
 
Thread Tools Search this Thread
  #1  
Old 06-09-2013, 08:29 PM
eroomnek eroomnek is offline
Inserted Coin
 

Join Date: Apr 2011
Posts: 5
Credits: 11,604.20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
eroomnek is on a distinguished road
Default TZ Ball Lock Release Weak

The upper lock release on my TZ is having difficulty popping the ball out and requires several tries when only one ball is present. If there are two balls locked, then the ball rarely gets popped out and into play. I have replaced the coil on assembly A-16307 assembly and made sure that the end of the plunger was not broken off. Anyone have a similar issue and have a fix for it? Thank you.
Reply With Quote
  #2  
Old 06-11-2013, 08:33 PM
pinballdaveh's Avatar
pinballdaveh pinballdaveh is offline
Pinball Technician
 

Join Date: Aug 2012
Location: poconos
Posts: 881
Credits: 57,037.82
Thanks: 213
Thanked 311 Times in 265 Posts
Rep Power: 17
pinballdaveh is a jewel in the roughpinballdaveh is a jewel in the roughpinballdaveh is a jewel in the roughpinballdaveh is a jewel in the rough
Default

lock release issue. since the coil was changed the problem is usually the driver transistor that operates that coil. in that low power solenoid circuit Q46 drives that coil. also a 68 ohm and a 2.7k ohm resistors in that circuit need to be checked. Q46 tip102 might have been stressed and not giving full output. changing Q46 would be the first thing i would try.
Reply With Quote
  #3  
Old 08-24-2013, 02:45 PM
eroomnek eroomnek is offline
Inserted Coin
 

Join Date: Apr 2011
Posts: 5
Credits: 11,604.20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
eroomnek is on a distinguished road
Default works in diagnostic mode but not during game play

Finally found some time to address this issue again. It is still unresolved, but here is what I have done:

- checked circuit. -60V measured at coil
- replaced coil and plunger
- filled holes w glue and toothpicks retapped to ensure a tighet fit

The ball lock release operates great during diagnostic mode. I can have one ball in the lock hole and two others in the qeueu as a worse case scenario and they are ejected with no issues. However, during game play, the ball lock release is almost non existant and cannot push out one ball on its own.

Looking for direction. Apprecioate your help. Thank you.
Reply With Quote
  #4  
Old 08-24-2013, 06:07 PM
pinballdaveh's Avatar
pinballdaveh pinballdaveh is offline
Pinball Technician
 

Join Date: Aug 2012
Location: poconos
Posts: 881
Credits: 57,037.82
Thanks: 213
Thanked 311 Times in 265 Posts
Rep Power: 17
pinballdaveh is a jewel in the roughpinballdaveh is a jewel in the roughpinballdaveh is a jewel in the roughpinballdaveh is a jewel in the rough
Default

is there an opto board or a ball trough with swifches associated with that ball release, since coil is firing correctly during test.
Reply With Quote
  #5  
Old 08-25-2013, 07:45 PM
eroomnek eroomnek is offline
Inserted Coin
 

Join Date: Apr 2011
Posts: 5
Credits: 11,604.20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
eroomnek is on a distinguished road
Default

Yes, there is a ball trough switch to let the logic know that it needs to activate the ball lock release. I just checked the ball trough switch in both diagnostics mode and during game play. It works. Just that during game play, the ball lock release is feable at best. Can't push the ball out of the hole. Still works in diagnostics mode though.
Reply With Quote
  #6  
Old 08-26-2013, 09:38 AM
pinballdaveh's Avatar
pinballdaveh pinballdaveh is offline
Pinball Technician
 

Join Date: Aug 2012
Location: poconos
Posts: 881
Credits: 57,037.82
Thanks: 213
Thanked 311 Times in 265 Posts
Rep Power: 17
pinballdaveh is a jewel in the roughpinballdaveh is a jewel in the roughpinballdaveh is a jewel in the roughpinballdaveh is a jewel in the rough
Default

do you get a strong coil fire when you ground the tab of Q46 driver transistor during play mode and during attract mode? if you do get a strong fire on both the problem is prob input related such as cpu , data lines , or connections.
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Evolution Of The Flipper JonPurpleHaze Articles from Russ Jensen 0 11-07-2014 05:04 PM
INSIDE YOUR BINGO JonPurpleHaze Articles from Russ Jensen 0 11-07-2014 04:36 PM
tiltjlp's 1st PinGame Journal Article! JonPurpleHaze tiltjlp's Articles 0 11-05-2014 06:14 PM
shivaEngine's features JonPurpleHaze Pinball Nirvana's VP Tutorial Collection 0 11-05-2014 04:44 PM
Imported Messages (826 entries 7/2001 to 1/2012) JonPurpleHaze IRPinball's Guestbook 1 01-31-2012 12:09 AM


All times are GMT -4. The time now is 04:36 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Template-Modifications by TMS
Credits System provided by vBCredits II Deluxe (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.15 (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.