Pinball Nirvana Home Page

Go Back   Pinball Nirvana Forums > VP/VPM Help and Support > VP/VPM General Information and First Aid Station

VP/VPM General Information and First Aid Station Request Help about Visual Pinball or Visual PinMAME.

Reply
 
Thread Tools Search this Thread
  #1  
Old 11-01-2017, 07:32 PM
GSGregg GSGregg is offline
Inserted Coin
 

Join Date: Mar 2010
Location: Pasadena
Posts: 476
Credits: 42,677.06
Thanks: 234
Thanked 182 Times in 134 Posts
Rep Power: 13
GSGregg has a spectacular aura aboutGSGregg has a spectacular aura about
Default Lagging/Irregular Plunger and Flippers...

...on any session but the first (!?).

After a startup or restart, VP and VPM play normally (once I wait out the updates and/or scans that insist on stealing a few minutes of processor time), no matter whether I play a single game or a dozen or more. I play desktop VP8 and 9, mostly VPM tables, as non-VPM can't submit scores to PINemHi Leaderboard (which also acts as a front-end). Control is a conventional keyboard (Corsair K70 LUX w/ Cherry MX Red mechanical switches).

When I terminate the session, I can access the Internet, Windows Explorer, regedit, Control Panel, etc. and all is tolerable (if one tolerates a single-core AGP-8X comp running XP in this day and age). If/when I choose to begin another pinball session, however, things look normal until I press Start (#1); when I pull back the plunger (Enter) and release it, the ball may not launch for 3 - 5 seconds. When it does, it eventually approaches a flipper, which may not respond to a keypress for a second or more, then sticks open for a similar span, by which time I have slapped both keys numerous times to hit the ball. This activates a mind-of-its-own response in which it cycles open and closed at about twice per second until possibly exhausting its memory of my flailing presses. If the second flipper is cycled, it may or may not respond for several seconds.

The only way out of this is to Restart the computer, then open VP/VPM/PINemHi before doing anything else.

The only time I had this previously, I had changed my NVidia GeForce 6200 for my current ATI HD4670 1GB---suddenly I could no longer play the FullTilt! version of Space Cadet, or Pro Pinball Timeshock! The 4670 was and is the only AGP-8X vidcard made with 1GB of memory, and if it hadn't played VP satisfactorally, it would have been returned TOOT-SWEET!

Does anyone remember having this, and was there a remedy? Thanks, all!

Gregg
__________________
Reply With Quote
The Following User Says Thank You to GSGregg For This Useful Post:
Ike Savage (11-01-2017)
  #2  
Old 11-01-2017, 10:41 PM
Ike Savage's Avatar
Ike Savage Ike Savage is online now
Pinball Porcupine
 

Join Date: Jun 2003
Posts: 3,190
Credits: 272,423.53
Thanks: 968
Thanked 587 Times in 454 Posts
Rep Power: 52
Ike Savage is a name known to allIke Savage is a name known to allIke Savage is a name known to allIke Savage is a name known to allIke Savage is a name known to allIke Savage is a name known to all
Default

Shiva might have a good answer for you.

I used to write FAQ's and guides upon this stuff, but that was years ago. Before AJ pulled the plug.

TBH I guess your best bet is to copy-paste this query to VPF.ORG.
Reply With Quote
The Following User Says Thank You to Ike Savage For This Useful Post:
GSGregg (11-02-2017)
  #3  
Old 11-02-2017, 12:22 AM
shiva's Avatar
shiva shiva is offline
Pinball Wizard
 

Join Date: Oct 2004
Location: Abbotsford
Posts: 665
Credits: 61,388.28
Thanks: 0
Thanked 115 Times in 67 Posts
Rep Power: 21
shiva will become famous soon enoughshiva will become famous soon enough
Default

Hi. Been a long time since I touched VP. Reasons...

Can't really answer the question anymore, to many changes have been made to VP so it's now unrecognizable. Check task manager, see if it's in fact another program running that is taking up too many resources. Maybe you have a setting in the video manager that is causing this, just switch everything to it's lowest settings and work from there.

I just installed VPX myself, and the usual bugs happened of course. I would uncheck the higher graphics quality stuff first, Ambient is off, turn all the way to the left the details slider, and set the texture dimension to 1024 or 2048. I have to enable vsync on my computer because everything plays at lightspeed with older versions of VP. I believe in the code geeky way we all have been fostered with, you have VPdev type in 1. Forcing the FPS may make it play better, I have no idea what other things do, apparently the instructions require a rocket science degree just to be able to understand what is written in there.

Oh, the old standby, because even after 15 years, they still haven't fixed this bug. This I have to do to prevent VP/VPX from crashing, so it's the first thing you do, is right click the vpx icon, select properties,compatibility, and check "disable display scaling on high DPI settings" If I remember correctly, this helped with lag as well. Been many many years though.

Off the top of my head, hope it works out.
__________________

FaceBook Page for all my Rants,raves and projects
https://www.facebook.com/paul.sanderson.3745496
Next project: FPx Template engine.

Last edited by shiva; 11-02-2017 at 12:30 AM.
Reply With Quote
The Following 2 Users Say Thank You to shiva For This Useful Post:
GSGregg (11-02-2017), Ike Savage (11-02-2017)
  #4  
Old 11-05-2017, 06:58 AM
GSGregg GSGregg is offline
Inserted Coin
 

Join Date: Mar 2010
Location: Pasadena
Posts: 476
Credits: 42,677.06
Thanks: 234
Thanked 182 Times in 134 Posts
Rep Power: 13
GSGregg has a spectacular aura aboutGSGregg has a spectacular aura about
Default

Left out of the overly-long opening post:

When the flippers and plunger are acting up, the ball, bumpers and slings , as well as VPinMAME, are fine. Can't say the same for the Lock keys, though; since my left-flipper fingers often graze the CAPS LOCK key, it is turned on - then off - almost constantly.....but when things are haywire, the CAPS LOCK key is sluggish turning on, then even more so turning off, etc., until it stays on - even after the close of the session. The other LOCK keys (Scroll and Number) are non-functional when CAPS LOCK is compromised. Then, as with the plunger and flipper keys, the only way out is a restart.

Playing VP without going through PINemHi, I can close a table without closing the Editor (an option one doesn't have when a front-end has its automatic routine), select another table, and have normal play continue. Closing the Editor, though, and opening it a second or additional time, brings on the malfunction.

I formatted this HDD and installed XP from CD in March and selected Bitdefender Free from a menu; later they put out a product called Security for XP and Vista and registration got me a six-month free license July 30 (I figure to have updated my comp to W8.1 32-bit by the time it expires). Trying to remember what may have been added since July 30 (as that seems to be the last time things behaved normally) , all I come up with is Catalyst Control Center, a reload of the GFX driver from CD (just in case), an update for Flash Player.....and my download history prior to Oct 6 has been scrapped?! Oh, well...thanks for reading.

Gregg
__________________

Last edited by GSGregg; 11-05-2017 at 07:07 AM.
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:00 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Template-Modifications by TMS
Credits System provided by vBCredits II Deluxe (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.15 (Lite) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.