Pinball Nirvana Home Page

Go Back   Pinball Nirvana Forums > Future Pinball > Future Pinball Discussion

Future Pinball Discussion Anything Future Pinball related

Reply
 
Thread Tools Search this Thread
  #1  
Old 06-24-2019, 08:33 PM
Salty58 Salty58 is offline
Inserted Coin
 

Join Date: Jun 2019
Posts: 2
Credits: 222.94
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 0
Salty58 is on a distinguished road
Default Kiss Lamp Issue

I have been refurbing a Kiss machine for a friend.
I have the play field all done.
Everything works and lights, as it should.
I have cleaned all 5 LED displays, and they work as they should.


I have cleaned all the lamp sockets on the display and replaced all the bulbs.
Other than a few of the lamps running down the left side of the display none of the bulbs light.
From what I have read; the Aux board controls the KISS lamps... The "S" works, and a couple bulbs in the "I" are very dim.



I've cleaned all the connections on the LED Lamp Driver and the Auxiliary Lamp Driver. Nothing "appears" to be blown on either board.


I'm considering just buying new boards, but I don't want to do that if there are other things I should test now.



I appreciate any help.



Jeff
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Template-Modifications by TMS
Credits System provided by vBCredits II Deluxe (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.15 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.